Bus Pirate 5 code compilation

I have installed all the components to compile the Bus Pirate 5 code including Visual Studio code on my Ubuntu 23.04 computer.
While building the code I get a very high number of Warnings:

[build] : warning: “PICO_PROGRAM_DESCRIPTION” redefined
[build] : note: this is the location of the previous definition

I don’t understand what the problem is. Can someone help me ?

1 Like

Look in cmake. It is set twice. A bad merge probably. It’s not going to effect the compile.

1 Like
pico_set_program_name(bus_pirate "bus_pirate")
pico_set_program_version(bus_pirate "0.0.4")
pico_set_program_description(bus_pirate "Bus Pirate Firmware for RP2040")

In CmakeLists.txt somewhere around here one of the lines is duplicated. That is causing the error. It drove me nuts for weeks because it didn’t show up in my search of the code.

1 Like

Hi Ian

I confirm, by removing the last repetition I no longer have a Warning when compiling the code.
I made a Pull Request on the Repository so we can avoid others having the same problem.

Best regard

1 Like

Thank you so much. I will also push the code I’ve been working on. I’m still using our private repo because it is connected to the build server. I haven’t had a chance to deal with all that. It’s on my list for this afternoon.

I pushed the latest code to github for the main firmware cleanup, as well as the new syntax_rework I’m doing.

I am connecting the build server now. I will use the public repos when the build server is going.

1 Like

After seeing your mention of this issue in chat last night, I replicated the issue. Once you pushed your changes back to the repo, I validated that the warnings received when compiling the code no longer existed. Thanks for making the pull request to avoid this same instance for other users. Have a great day!

Thank you again. I’m sorry I mooted the pull request, I will be better about that in the future. I moved over the build server now and will now be active in the public git.

On a side note: I tried a few ways to pass the git hash via cmake to set in the info menu (i command, says unknown). I’ve not been successful but will try some modifications to cmake tomorrow.

Also, if you think you’ll have more fixes like that, happy to give you access. Pirate bot should make a thread and post builds for any branch you make/work on.

Hi Ian

I’m not very practical but I can learn over time.

I downloaded the updates and I’m having problems again:

[cmake] CMake Error: CMake was unable to find a build program corresponding to “Ninja”. CMAKE_MAKE_PROGRAM is not set. You probably need to select a different build tool.

Let me start by saying that I only have this behavior on VS Code while if I compile from the command line I have no problem.

We should improve the documentation to install and configure the development environment correctly, this is very important :slight_smile:


I absolutely agree. I did what I could, but much build out is needed.

As for the error: I checked in my .vscode directory . Have you tried clean reconfigure in the vscode ide? That’s what does it for me.

1 Like

Yes, I cleaned everything up and did the installation all over again. Believe you can configure the settings on your Cmake.
Now I’m ready, I’m waiting for the release of the REV9 to buy it :slight_smile:

1 Like

Glad you got it working!

REV9 is at FCC testing now. I hope we have the injection molded enclosures next week. Tooling always lags everything else though.

Hey, PM me your address and I’ll mail you rev8 in one of the cases I printed. I don’t have extra cables, but can send some rev1 pins.