File System no longer mounts

I used the hardware boot option to load the latest firmware

Firmware main branch (2024-06-08T13:24:59Z)

I was testing the new help, and as I was having problems using the “$” command, I just unplugged the BP. I wanted to test something.,

Now the file system no longer mounts. So I tried the hardware boot button so I could mount the RP1-RP2 file system. That file system no longer mounts.

In other words - I can no longer update my BP, unless I use some external hardware. Any suggestions?

I rebooted my Ubuntu laptop, and plugged in my BP. The file system mounted.
I connected to the BP, types "$: to get it into boot mode. The file system never mounted.

I unplugged and reconnected the BP. I can see the two pseudo-terminals (ttyACM0/ttyACM1), but the file system doesn’t mount.

So I tried unplugging and reconnected the BP. It eventually worked.


1 Like

Doesn’t seem to like the sudden disconnect. Maybe we should issue a USB MSD reset before jumping to bootloader?

I pushed an update that disconnects the storage device before jump to bootloader. This is untested, but thought it might help you a bit.

Something still not right. If I reset UDEV, and use the physical boot button, the LED’s are off and /media/$USER/RPI-RP2 mounts.

If I then unplug and replug the BP, /media/$USER/BUS_PIRATE5 mounts.

If I connect to the BP, and type “#” to do a reset, no file system mounts and the LED’s flash.

If I reset UDEV, reconnect the BP, the file system mounts.
I then connect to the BP, and type “$”, the file system unmounts, and does not remount. The LED’s stay on and do not change.

If I do not unplug the BP after I type “$”, then

  1. No file system mounts
  2. The LED’s stay on constantly
  3. No /dev/tty’s show up.

If I unplug and replug the BP, then

  1. no file system mounts
  2. the /dev/ttyACM0 and 1 show up but I don’t have permission to connect to them
  3. the LED’s flash

If I again replug the BP, it’s the same as above.

If I again replug the BP - it works normally.

If I connect to the BP and type “$”, then disconnect the BP and restart UDEV and replug the BP, I can connect to the BP but the file system doesn’t mount

I think this has something to do with the MTP (Media Transport Protocol). I also see

Volume was not properly unmounted. Some data may be corrupt. Please run fsck.

BTW, I ran fsck to check the file system but did not make any changes. It did report

There is no label in boot sector, but there is volume label ‘BUS_PIRATE5’ stored in root directory

More into on MTP [Media Transfer Protocol - Wikipedia](https://Wikipedia Entry on MTP)

For some reason Ubuntu is confused if it’s an MTP device of a normal file system. An MTP device won’t get corrupted if suddenly unplugged, but a FAT-32 can get corrupted. So perhaps when I unplug the BP, the file system gets corrupted?

perhaps I should wait until the format command works.

With the current exposure of the file system via FAT32 (as a mass storage device), there are known edge cases where the file system will be corrupted.

Does the BP5 firmware implement MTP?

If yes, then it perhaps the FAT32 file system that is backing this should always be read-only for the host (PC). That would 100% resolve the known corruption issues, but would require using MTP to write to the BP5 volume.