Hardware Issues. Doesn't boot sometimes, LEDs blink randomly

Got my Bus Pirate 5 recently (I guess second batch, after Chinese Festival) and wondering if someone experiences same issues:

  1. Doesn’t boot every time you plug in, have to reattach 10-20 times for successful attempt.
  2. When it finally boots, two bottom LEDs are blinking like crazy (regardless of BP5 configuration). See video here

LED issue

I have tried several laptops (Mac and Win), different cables, updated to the most recent FW version - same thing

Interesting observation - boot loader mode works every time (that is how I am able to update firmware).

Thanks for any suggestions.

Hi @alexhude,

Thanks for posting, I’m really sorry your Bus Pirate arrived in this state.

A couple things stand out to me:

  1. The LCD is working, so you have the right firmware installed
  2. The LEDs are a chain, so if one goes out, the LEDs after it stop working. It looks like 2 LEDs are working, but they are not showing any recognizable pattern.
  3. How the inability to connect is related, I cannot say with any certainty. Especially if the bootloader works well.

My guess is there is a short, probably from a stray solder ball, between the LED driving pin and something else critical. Unless you’d like to poke around the PCB and try to find the issue, I suggest you open a support ticket and we’ll send a replacement.

bus_pirate5_rev10-test-no-leds.zip (164.4 KB)

Just out of curiosity, here is a firmware with the LEDs disabled. If you’d like to test it, I’d love to know if the USB connection problems persist with the LEDs disabled. Maybe at least we can find out if the two issues are obviously related somehow.

When you were able to connect, did you try the self-test? ~ command.

Hi @ian

Just out of curiosity, here is a firmware with the LEDs disabled. If you’d like to test it, I’d love to know if the USB connection problems persist with the LEDs disabled.

Absolutely, I have tried your firmware with disabled LED and it indeed fixed USB issue, so you are right, some LED shorts are breaking boot.

I suggest you open a support ticket and we’ll send a replacement.

Can you please send me link to support system where I can create a ticket?

Thanks!

Thank you for the feedback, that is interesting.

Your order confirmation email should have a link to your order page where you can raise a support ticket.

1 Like

Hi @ian

I have lodged support ticket, but didnt get any confirmation email, so not sure if it went through. Appreciate if you can confirm that I did everything right :slight_smile:

Thanks.

I’m sorry about the email issue. I alerted the office that we need a defect, they’ll mail a new one Monday.

Hi @Ian ,

Sorry for bothering again, but support people sent me an email (they found my details) asking if I want a replacement. However, they did that from noreply@DirtyPCBs.com that bounces all messages back, so I cant reply “YES” to their question :slight_smile:

Could you please let them know that “yes, I would like a replacement” or gimme alternative email to reply.
Really appreciate that :pray:

I let them know, sorry about that.

1 Like

My new buspirate Order # 2068761 had very similar symptoms, although the “2 bottom LEDs blinking like crazy” didnt happen.

But i had to plug it in and out 20-30 times for it to recognize power. tried with a few different cables and machines. I am talking with DirtyPCBs now and they seem very nice, but figured i would post here to let you know that the No-LEDs version of the firmware did in fact fix my USB plug-in issue as well.

1 Like

Thank you for letting me know. It seems like we have a corner case of some sort.

Are you in a position to mail that to me in the EU or US after you get a replacement? I’d really love to solve this one. It’s really interesting.

1 Like

yeh sure thing. feel free to email me to work out details, or however you prefer to communicate.
as i was telling DirtyPCBs its an odd issue because nothing has changed when it decides to work. i can have it booted and super carefully unplug the USB from computer and plug back in immediately, and it acts like its not getting power the next time.
super random timing when it does work. im really not doing anything differently. When it does boot… it works flawlessly. i even tried to bump it around a little when it is working to see if its just a loose connection, but nothing. it (seems) fine once booted.

Im in the US btw

1 Like

Thank you. Will do.

Do you know the batch? Does the PCB look green or purple?

1 Like

purple. my eyes were playing tricks on me through that smokey color, had to take off the case

1 Like

Thank you. First from that batch with an issue. Good to know.

1 Like

Hi @ian

My faulty PCB is green and while I cant send it to US/EU (it is pretty expensive from AU), I can look into the issue in my own hw hacking lab. And I did that yesterday when I saw a message from HEDoRAH about similar issue.
I have carefully removed cover and I think there are two issues: blinking LED and boot.

  1. LED issue was caused by broken LED when case was assembled, LED704 was bended, pads were partially torn off probably causing shorts. I have removed this LED and restored pads with UV mask etc.I didnt put LED back yet cause want to be sure that LED itself is not causing short, obviously remaining leds in chain are now disconnected.
  2. However, that didnt solve problem with boot, so I started to play around with different firmwares and found out odd thing. If you get device into bootloader mode and update fw, it will boot after soft reset all the time (also all LEDs before removed one are working). Therefore device boots all the time if:
  • I flash fw from you where software doesnt use LEDs
  • we get to main fw from bootloader over soft reset.
  1. I have checked some voltages on various components in a chain and it seems to match the schematics.
  2. I thought maybe some other LED is messing with circuit, so I removed R502 and disabled entire LED chain, that didn’t help with boot (I put R502 back).
  3. Next thing I tried - under thermal camera I check if something is generating lots of heat during failed boot. And no, apparently only two elements are slightly warm (similar temperature comparing to booted state): U401 and RP2040 itself. Other chips like U503 seem off completely. I checked U401 carefully and confirmed there is no short and it indeed produces 3V3.
  4. Finally I tried to prove that issue is not mechanical (when you insert USB cable). For that I got usb hub with button to turn on/off usb port. I secured cable and device and just tried to boot it with button on hub - same success rate (boots 1/10). So it is not mechanical.

Therefore, I believe there is probably an issue with some of the caps on +VUSB power or LED rail or other passives.

Feel free to let me know if you want some other things to try.

Alex.

3 Likes

Thank you so much for the analysis. I’m going to first look into the LED manufacturing error.

I’ll ask the office to check the caps origin. We didn’t cheap out there, we bought Samsung caps from a licensed distributor.

This is such an odd one. I can’t help but think it’s a firmware issue, but I can’t think of anything in the startup that’s blocking. Also the multiple pairings of dead led and startup issues. It’s going to be fascinating when I find a solution.

1 Like

Caps is just a wild guess, I wish I know how to narrow that down.

I spent more time testing firmware and noticed that VERY first rev10 firmware also boots fine EVERY TIME (Bus Pirate 5 auto build: main branch - #61 by ian), and I think this is because it doesn’t try to blink all leds before boot like recent firmware does. Maybe it is over-current in some component that is causing everything to halt?

P.S. I put LED back after fixing pads, and entire chain works now (only with REV10 or soft reset obviously)

2 Likes

Good find! I’ll go back to that commit and check the startup sequence.

i think you are on to something there, because as i noted, it seemed to work fine out of the box. i booted it 4 or 5 times before updating to latest firmware. and then of course it works now with the “disabled LEDs” fw ian posted. I flashed latest fw again before packing it up (didnt want to look like an idiot and it was magically fixed). i will get it in the mail today or tomorrow

Yes, it works out of the box because it is flashed with very first REV10 from the factory which doesnt trigger boot issue. So I only had blinking LED issue initially, and I thought it is sw bug so I flashed with recent fw and hit boot issue.