Storage Not Detected on BP5

Hello there,

I’ve recently started using the BP5 in order to perform some SPI read/write operations.

After several hours of use, my BP5 crashed and I know encounter many issues and can’t make it work properly. Here is what happened after the crash:

  • Both TTY and MTP aren’t working at all on Windows/MacOS computers. The 2 TTY devices appears when I connect the BP but they crash as soon as I try to connect.
  • On Ubuntu, I managed to connect to the TTY and I now have access to the device. MTP is also partially working.

Thus, I stayed on Ubuntu to debug the BP. However, It seems that the Storage isn’t properly working, I suspect that it broke while I was using it to write a chip over SPI.

Here are a few screenshots of the issues:

Image 1
Image 2

As you can see, the results of several commands aren’t stable.

  • Upon connecting/disconnecting, the MTP device doesn’t show the same files (sometimes I can access my files, sometimes its just a README.txt).
  • The ls command sometimes shows the internal storage sometimes nothing, rm or mkdir don’t work.
  • I can’t format using the format command

There is also this Configuration file: Not detected when I type i.

All this drived me to think that the storage may be faulty. However, It’s weird that I sometimes can access the files, etc.

I tried many different things to fix the pb, none worked (changed firmware 500 times, changed computer, OS, USB cable…). I’m abit sad because I only used the BP for 3-4 hours :no_mouth:

I searched many topics on this forum but It seems that nobody encountered the same problem…
Does anybody have a suggestion?

Thank you!

EDIT: sometimes the self test shows another error - VREG==VOUT: 4561 > 4357 ERROR!! and the storage appears as OK… It happens after not using the BP for several minutes but when it heats up this error disappears

This may be related to the problems I have encountered. I’ve seen corrupted disks. But I’ve never seen “format” on the BP fail.

It’s very weird to have the format fail indeed. I feel like the disk is physically damaged but I don’t really know how to check it.

I had the idea to open the BP & use another SPI reader to read 1Gbit SPI NAND but I’m not even sure that I could identify if its broken doing so.

Hi @maximedelis,

What a strange issue, thanks for reporting it. I think the easiest thing is to open a support ticket (assume you purchased from Dirty PCBs) and I’ll send you a new one.

1 Like

Hello @ian ,

I opened a support thanks for your answer!

Still, I’d like to try and repair the broken BP. I wonder if there was a way to flash the NAND (or format it) using another SPI programmer? Are there any specific instructions regarding the NAND?

Thank you!

you have the ‘format’ command that will reformat the nand flash, this method will erase any existing files.

Hi. As mentioned, the format command isn’t working. I’m trying to fix (or replace) the NAND.