UART mode problems

Hi everyone

I think I’m doing something wrong, I need a little help.
I’m playing with UART to read a router console.

The first test I did with a small USB serial module as shown in the photo:

Everything works perfectly and I was able to read the information during boot.

Next I wanted to do the same thing with Buspirate 5 by connecting in the same way as the USB serial module

Mode selection

  1. HiZ
  2. 1-WIRE
  3. UART
  4. I2C
  5. SPI
  6. LEDs
    x. Exit
    Mode > 3

Use previous settings?
UART speed: 115200 baud
Data bits: 8
Parity: None
Stop bits: 1
y/n> y

Actual speed: 115207 baud
Mode: UART

  1. Transparent UART bridge
  2. GPS NMEA Decoder
    UART > 1

UART bridge. Press Bus Pirate button to exit.

The UART pin mapping appears on the Buspirate 5 display
IO4 TX →
IO5 RX ←


Unfortunately when I turn on the Router I get nothing.

Am I doing something wrong ?

I often make mistakes with TX and RX. I.e is it RX on the receiving device, or RX as in this needs to be connected to RX on the sending device. First simple thing to try, to be sure, is swapping the two around on one of the devices, and seeing if that helps.

Hi nRatto

As I had written, I had connected the Buspirate in the same way as the USB serial module which had worked.
I clearly tried to do this but it didn’t work.

I think you might need to power the buffers. Either with the bus pirate W command or an external voltage on vout/vref pin. Without a voltage the io buffers are in partial power down mode.


Setting the power with the W command works!!!
I had a bit of trouble with the request:

Power supply
Volts (0.80V-5.00V)
x to exit (3.30) > 3.30v
3.30V requested, closest value: 3.30V
Set current limit?

If for this last question about power I press ENTER or a number greater than Zero everything freezes and I need to unplug the Busspirate5 from the USB
In order to move forward I am forced to answer with n and by magic we begin to read data from the serial number.

Perhaps a default value would be useful in this case?

However, I am already very happy…a small step forward

Glad it is working, and thank you for the bug report.

I have not seen the freezing issue, but I have some guesses. I will check it out.

I sent you a engineering sample board right? Some of those were assembled poorly, DREG had to resolder the main connector after discovering a power issue. Still shouldn’t freeze…

That prompt was hastily added because originally there was no way to override the current limit. It should have a default value and a Y/N prompt. Currently there is no prompt function to do clean Y/N prompts. I’ll fix that this week.

Yes, my board is a REV8 that you sent me a few weeks ago.

Did DREG just desolder the connector and re-solder? Did he make any other corrections?
Did he write it on this forum? I don’t think I’ve found anything on this topic.

Thank you

The connector was poorly soldered; I simply added more solder and fixed it

Ok, I’ll check in the next few days. Thank you

I’m not suggesting that specifically is your issue, just that that batch of boards was problematic and was never fully self-tested. It was just for me to do stress testing and make sure they weren’t damaged by back powering and such.